Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Unable to Set the Correct $_ADOdbPath
09-14-2011, 09:33 PM,
#1
Unable to Set the Correct $_ADOdbPath
Hi

I downloaded and am trying to install v3.2.0. Ran through check.php and all paths are "Ok", except for settings->_ADOdbPath. See below for the full result :

LetoDMS 3.0.0 check configuration (check version : 3.00-06)

Apache information not accessible

Check PHP configuration

PHP version: 5.2.14
gd2 : Ok
mbstring : Ok
database - mysql - : Ok
ldap (optional) : Error

Active PHP extension: php_ldap (optional)

Check LetoDMS configuration
settings->_rootDir : Ok
settings->_coreDir : Ok
settings->_httpRoot : Ok
settings->_ADOdbPath : Error

Current value : letodms/adodb5/
Suggestion value : PLEASE INSTALL ADOdb


adodb missing, CAN'T TEST DATABASE

Check other configuration
Cookies : OK

Informations

Limit size for uploading file (upload_max_filesize): 20M

Limit size for uploading file (post_max_size): 8M

SMTP server (SMTP): localhost

Limits of the execution time (max_execution_time): 30 s

Safe mode (safe_mode): OK

Open Basedir (open_basedir): OK

END


I have already uploaded adodb5 (in letodms folder), but it seems to be unable to find the path. I've tried all paths below, but to no avail :
/home/my_website/public_html/letodms/adodb5/
home/my_website/public_html/letodms/adodb5/
letodms/adodb5/
adodb5/
/adodb5/


Please help. Thanks.
Reply
09-15-2011, 03:13 PM,
#2
RE: Unable to Set the Correct $_ADOdbPath
I've managed to set a correct path. Got my clue from check.php ~line 350 :
if (file_exists($settings->_ADOdbPath."/adodb/adodb.inc.php"))

It looks like check.php is hardcoded to use "adodb" folder and $_ADOdbPath should be set to point to the folder that contains "adodb", not to directly the "adodb" folder itself. So, I set $_ADOdbPath path to :
/home/my_website/public_html/letodms
(note: without the ending forward slash)
And voila, adodb is finally detected Ok.
Reply
09-16-2011, 12:18 PM,
#3
RE: Unable to Set the Correct $_ADOdbPath
(09-15-2011, 03:13 PM)developer Wrote: I've managed to set a correct path. Got my clue from check.php ~line 350 :
if (file_exists($settings->_ADOdbPath."/adodb/adodb.inc.php"))

It looks like check.php is hardcoded to use "adodb" folder and $_ADOdbPath should be set to point to the folder that contains "adodb", not to directly the "adodb" folder itself. So, I set $_ADOdbPath path to :
/home/my_website/public_html/letodms
(note: without the ending forward slash)
And voila, adodb is finally detected Ok.

check.php may indeed not always say the truth. There has been some modifikations in the past check.php isn't aware of.

Uwe
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)

Contact Us | LetoDMS Community Forum | Return to Top | | Lite (Archive) Mode | RSS Syndication