Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Zend Framework Lucene error, problem with full text index
09-20-2013, 08:11 AM,
#1
Thumbs Down  [SOLVED] Zend Framework Lucene error, problem with full text index
After my installation of SeedDMS, I troubled a lot with Send Framework. It did not seem to work properly, even though I did a lot of changes in the php files under lucene and under Zend Search.

It kept sending these exceptions:

Fatal error: Cannot redeclare class Zend_Search_Lucene_Document in ....

Fatal error: Interface 'ZendSearch\Lucene\Analysis\TokenFilter\TokenFilterInterface'

Fatal error: require_once(): Failed opening required 'Zend/Search/Lucene.php'

and so on.

My problem was basically that SeedDMS could not find Zend Search_dir anywhere. I installed the full bundle of Zend Framework in my mac through MacPorts, and the source of my desperation was that I, naively installed the last version: ZendFramework2.

This version does not have bundled the Search files, the only solution was to uninstall it and install ZendFramework1 using the following simple command in a terminal:

sudo port install ZendFramework1


I hope it helps someone out there in their quest to install SeedDMS/LetoDMS
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)

Contact Us | LetoDMS Community Forum | Return to Top | | Lite (Archive) Mode | RSS Syndication