Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Update from v2.0.2 to v3.4.0RC4
11-25-2012, 07:04 AM,
#1
Update from v2.0.2 to v3.4.0RC4
Hi,

my name is John and I have a question on updating letoDMS to the latest version. On my DS211 the v2.0.2 is running since 2010. Now I got a new DS412 and it was a lot easier than expexted to put letoDMS on my new Diskstation.

Now I want to upgrade letoDMS to the latest version but I do not really know how I should do this.

Can you please help me with updating it?

regards,
John
Reply
11-26-2012, 02:58 AM,
#2
RE: Update from v2.0.2 to v3.4.0RC4
(11-25-2012, 07:04 AM)John_k22 Wrote: Hi,

my name is John and I have a question on updating letoDMS to the latest version. On my DS211 the v2.0.2 is running since 2010. Now I got a new DS412 and it was a lot easier than expexted to put letoDMS on my new Diskstation.

Now I want to upgrade letoDMS to the latest version but I do not really know how I should do this.

Can you please help me with updating it?

There is no upgrade straight from 2.0.2 to 3.4.0. You have to do any single upgrade in between. The crucial parts are the database updates.
The update from 3.2.0 to 3.3.0 also needs to run a php script.
All needed updates are in the update-x.x.x folders. The settings file
has changed too. You have to create the new xml file manually.
You should definitely make a backup, before you do the update.

Uwe
Reply
11-26-2012, 04:31 AM, (This post was last modified: 11-26-2012, 04:32 AM by John_k22.)
#3
RE: Update from v2.0.2 to v3.4.0RC4
I still didn't get all of it.

* I downloaded every single version after my 2.0.2 then extraxted the files to my dms folder on my NAS and overwrote all files when asked to.
* I run all update.php scripts when found them but mostly there are just update.sql files in the update filders. I run them by putting the address into my web browser. I just got a blank screen there.
* I did tis updates just to version 3.2.2 because the files and directories look different with v3.3.0.
* when I lauched letodms after the updates I got the message 'You does not seem to have a valid configuration. Run the install tool first.' in my browser.

I think that I did something wrong (I can go back with my backup).

Could you please explain how exactly I should update my version. Mybe you can provide me an example?

John
Reply
11-26-2012, 03:19 PM,
#4
RE: Update from v2.0.2 to v3.4.0RC4
(11-26-2012, 04:31 AM)John_k22 Wrote: I still didn't get all of it.

* I downloaded every single version after my 2.0.2 then extraxted the files to my dms folder on my NAS and overwrote all files when asked to.
* I run all update.php scripts when found them but mostly there are just update.sql files in the update filders. I run them by putting the address into my web browser. I just got a blank screen there.
* I did tis updates just to version 3.2.2 because the files and directories look different with v3.3.0.
* when I lauched letodms after the updates I got the message 'You does not seem to have a valid configuration. Run the install tool first.' in my browser.

I think that I did something wrong (I can go back with my backup).

Could you please explain how exactly I should update my version. Mybe you can provide me an example?

There is no example of the whole update from 2.0.2 to 3.4.0.

I propose you start with an update to 3.0.0 which is already a big step because the configruation file format has changed from php to xml.

I also propose to change your database engine from myisam to innodb if not done already. You have to do this manually.

Uwe
Reply
11-26-2012, 03:58 PM,
#5
RE: Update from v2.0.2 to v3.4.0RC4
(11-26-2012, 03:19 PM)steinm Wrote: There is no example of the whole update from 2.0.2 to 3.4.0.
didn't expect this but I got stuck way before v3.4.0 ...

(11-26-2012, 03:19 PM)steinm Wrote: I propose you start with an update to 3.0.0 which is already a big step because the configruation file format has changed from php to xml.
But I do not know how.
I downloaded the 3.0.0 version as this is the next version to my 2.0.2 and extracted all files into my dms folder. I had to overwrite many files during copy.

There is no "update.php" within the "update-v3.0.0" folder so I do not now how I can update it. letoDMS also tells me that it is not propper installed when starting it after I put the new files into the dms folder.

(11-26-2012, 03:19 PM)steinm Wrote: I also propose to change your database engine from myisam to innodb if not done already. You have to do this manually.
I do not have any clue. I just installed letoDMS and using it. I do not have knowledge on php or sql ...
Reply
11-26-2012, 08:30 PM,
#6
RE: Update from v2.0.2 to v3.4.0RC4
(11-26-2012, 03:58 PM)John_k22 Wrote:
(11-26-2012, 03:19 PM)steinm Wrote: I propose you start with an update to 3.0.0 which is already a big step because the configruation file format has changed from php to xml.
But I do not know how.
I downloaded the 3.0.0 version as this is the next version to my 2.0.2 and extracted all files into my dms folder. I had to overwrite many files during copy.

There is no "update.php" within the "update-v3.0.0" folder so I do not now how I can update it. letoDMS also tells me that it is not propper installed when starting it after I put the new files into the dms folder.

You have to run the sql statements UPDATE-v3.0.0/update.sql in your favorite database client. Unfortunately, the update from 2.0.2 to 3.0.0 isn't very smooth, because of some many changes.

In your case it might be an option to install 3.0.0 first and then switch the database to your current database and run the above sql statements.

Uwe
Reply
11-27-2012, 05:32 AM,
#7
RE: Update from v2.0.2 to v3.4.0RC4
I installed v3.0.0 and switched the DB and run the update.sql. It seems that it worked Smile
I can see all documents and can download them or update and save them.
But I cannot create ne documents. I always get the message 'An error has occured' when saving new documents. It doesn't matter if I use the old data path or if I make a new one.

What can I do?
Reply
11-27-2012, 10:36 PM,
#8
RE: Update from v2.0.2 to v3.4.0RC4
(11-27-2012, 05:32 AM)John_k22 Wrote: I installed v3.0.0 and switched the DB and run the update.sql. It seems that it worked Smile
I can see all documents and can download them or update and save them.
But I cannot create ne documents. I always get the message 'An error has occured' when saving new documents. It doesn't matter if I use the old data path or if I make a new one.

What can I do?

My first guest would be wrong file permissions in the content directory.

Uwe
Reply
11-28-2012, 03:21 AM,
#9
RE: Update from v2.0.2 to v3.4.0RC4
(11-27-2012, 10:36 PM)steinm Wrote: My first guest would be wrong file permissions in the content directory.

Uwe
That's what I also thought and therefore I double checked it but all permissions are on 777.
What I do not understand is that in my web folder I am running v2.0.2 without problems. I can upload documents, edit them and delete them.

In the same web folder I installed the v3.0.0 but I cannot upload documents. All folders do have the same owners and permissions. I run the check.php and it shows that everything is ok. Even if I link the data path to the one of the v2.0.2 I cannot upload documents with 3.0.0. But I do get a log file ... strange that it can write a log file but not the document.

The log file says :
2012/11/27 22:19 admin (190.160.0.126) op.AddDocument UI::exitError error=Ein Fehler ist aufgetreten.<br />Bitte Administrator benachrichtigen.<p> pagetitle=LetoDMS - Ordner: test

I read more or less all related threads in this forum and this seems to be a problem to more than me.

Is this an issue which is related to letoDMS.Forum:File upload Problems?

John
Reply
11-28-2012, 01:26 PM,
#10
RE: Update from v2.0.2 to v3.4.0RC4
(11-28-2012, 03:21 AM)John_k22 Wrote:
(11-27-2012, 10:36 PM)steinm Wrote: My first guest would be wrong file permissions in the content directory.

Uwe
That's what I also thought and therefore I double checked it but all permissions are on 777.

If permissions are not the problem it may be a database problem.

Put a
PHP Code:
$db->_conn->debug 1

right after the line

PHP Code:
$db->connect() 

This will cause many messages. Do the upload again post the messages.

Uwe
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)

Contact Us | LetoDMS Community Forum | Return to Top | | Lite (Archive) Mode | RSS Syndication