Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
mapped network folders support
06-03-2011, 05:24 AM,
#1
mapped network folders support
I'm using letoDMS in WAMP.
Is it possible to put the content directory on a mapped network drive?
I'm getting error messages when I try to add a new file to a folder.
Reply
06-03-2011, 02:54 PM,
#2
RE: mapped network folders support
hi

check mapped network drive RIGHT. Set EVERYONE.

Under Windows, user used by Apache is SYSTEM LOCAL.

doudoux
Reply
06-03-2011, 11:49 PM,
#3
RE: mapped network folders support
Hi Doudoux,

I'm on Windows XP Pro, and the mapped drive is a folder on DLink DNS-323.

Are you referring to the mapped drive's properties-security settings?
It only lists:
501 (Unix Group\501)
Everyone
nobody (Unix User\nobody)

I tried adding the user 'System Local' but that doesn't exist. I could only find 'SYSTEM', or 'LOCAL SERVICE'.
I also tried right click mapped drive, properties, security tab, select 'Everyone' group, click allow full control, then apply. However, the settings don't stick.

Reply
06-06-2011, 03:21 PM,
#4
RE: mapped network folders support
(06-03-2011, 11:49 PM)broebel Wrote: I also tried right click mapped drive, properties, security tab, select 'Everyone' group, click allow full control, then apply. However, the settings don't stick.

Hi

set 'Everyone' in your NAS settings and not in windows explorer

doudoux
Reply
06-06-2011, 11:57 PM,
#5
RE: mapped network folders support
(06-06-2011, 03:21 PM)Doudoux Wrote: Hi

set 'Everyone' in your NAS settings and not in windows explorer

doudoux

My NAS is already configured for read/write permission for everyone on that folder. Is there anything else I can try?
Reply
06-07-2011, 01:15 AM,
#6
RE: mapped network folders support
ok i see

i have the same problem in my work.

you mount network folder. This mount is available only for your login and not for LOCAL SERVICE or SYSTEM.

Try without mount:
"\\nas01\Data\Temp\data"
or
"\\IP\Data\Temp\data"

doudoux
Reply
06-07-2011, 02:24 AM,
#7
RE: mapped network folders support
(06-07-2011, 01:15 AM)Doudoux Wrote: ok i see

i have the same problem in my work.

you mount network folder. This mount is available only for your login and not for LOCAL SERVICE or SYSTEM.

Try without mount:
"\\nas01\Data\Temp\data"
or
"\\IP\Data\Temp\data"

doudoux

I assume you are referring to the path used in conf.Settings.php. I tried the following:
var $_contentDir = "\\\\<nas ip>\\<folder>\\letodata\\";

I'm still getting an error when uploading a document. Do I need to recreate leto database from scratch?
Reply
06-07-2011, 03:44 AM,
#8
RE: mapped network folders support
Change \\ by /

var $_contentDir = "//<nas ip>/<folder>/letodata/";
Reply
06-07-2011, 05:01 AM,
#9
RE: mapped network folders support
(06-07-2011, 03:44 AM)Doudoux Wrote: Change \\ by /

var $_contentDir = "//<nas ip>/<folder>/letodata/";

I tried your suggestion but it still doesn't work. It looks like the log file is being created but perhaps the problem is with creating folders?
Reply
06-21-2011, 11:48 PM, (This post was last modified: 06-22-2011, 12:06 AM by broebel.)
#10
RE: mapped network folders support
I still haven't gotten this to work.

I also tried on a windows network share, thinking that maybe it is something specific to the NAS, but I still cannot upload files if the $_contentDir is set to a non local folder.
Please advise.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)

Contact Us | LetoDMS Community Forum | Return to Top | | Lite (Archive) Mode | RSS Syndication