Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FTP acces to upload files and folder
10-21-2011, 10:53 PM,
#11
RE: FTP acces to upload files and folder
(09-28-2011, 09:26 PM)steinm Wrote:
(09-27-2011, 01:03 AM)amine2018 Wrote: Any news about the ftp transfert for file ??

What about webdav? Does it help you?

Uwe

Hi Uwe,
webdav would certainly help me! I've managed to install and load the webdav component in letoDMS 3.2 and folder listing works fine. Creating files does not work at all however. It seems to be implemented though, isn't it? Using Transmit I get error 500..

Any suggestions would be very much appreciated!

Tobias
Reply
10-22-2011, 01:04 AM,
#12
RE: FTP acces to upload files and folder
(10-21-2011, 10:53 PM)gouwron Wrote:
(09-28-2011, 09:26 PM)steinm Wrote:
(09-27-2011, 01:03 AM)amine2018 Wrote: Any news about the ftp transfert for file ??

What about webdav? Does it help you?

Uwe

Hi Uwe,
webdav would certainly help me! I've managed to install and load the webdav component in letoDMS 3.2 and folder listing works fine. Creating files does not work at all however. It seems to be implemented though, isn't it? Using Transmit I get error 500..

Any suggestions would be very much appreciated!

It is implemented and I used it even with larger files. I will check again next week.

Uwe
Reply
10-22-2011, 05:34 PM,
#13
RE: FTP acces to upload files and folder
Hi Uwe,
could it be a 'simple' permissions problem? My data folder has chmod 777, but all the subfolders that were created by the dms itself have 755 and hence the webdav user might not have write permissions?
Unfortunately I can't change the permissions, because they were created by the dms - and I as ftp-user don't have the permissions to change their chmod...

By the way, I used this:
http://pear.php.net/package/HTTP_WebDAV_...redirected
webdav extension. Was that the correct one?

Thanks in advance, a working webdav would really make my day!
Tobias
Reply
10-24-2011, 03:12 PM,
#14
RE: FTP acces to upload files and folder
(10-22-2011, 05:34 PM)gouwron Wrote: Hi Uwe,
could it be a 'simple' permissions problem? My data folder has chmod 777, but all the subfolders that were created by the dms itself have 755 and hence the webdav user might not have write permissions?
Unfortunately I can't change the permissions, because they were created by the dms - and I as ftp-user don't have the permissions to change their chmod...

By the way, I used this:
http://pear.php.net/package/HTTP_WebDAV_...redirected
webdav extension. Was that the correct one?

Thanks in advance, a working webdav would really make my day!
Tobias

The permission is ok. The webdav user has nothing to do with the file permission. Your HTTP_WebDAV_Server is ok. I just tested it myself with the current version 1.0.0RC6.
There should be a log file starting with 'webdav-' in your content directory. Is there anything
suspious in it?

BTW, I tested with nautilus on debian linux sid.

Uwe
Reply
10-24-2011, 06:05 PM,
#15
RE: FTP acces to upload files and folder
(10-24-2011, 03:12 PM)steinm Wrote:
(10-22-2011, 05:34 PM)gouwron Wrote: Hi Uwe,
could it be a 'simple' permissions problem? My data folder has chmod 777, but all the subfolders that were created by the dms itself have 755 and hence the webdav user might not have write permissions?
Unfortunately I can't change the permissions, because they were created by the dms - and I as ftp-user don't have the permissions to change their chmod...

By the way, I used this:
http://pear.php.net/package/HTTP_WebDAV_...redirected
webdav extension. Was that the correct one?

Thanks in advance, a working webdav would really make my day!
Tobias

The permission is ok. The webdav user has nothing to do with the file permission. Your HTTP_WebDAV_Server is ok. I just tested it myself with the current version 1.0.0RC6.
There should be a log file starting with 'webdav-' in your content directory. Is there anything
suspious in it?

BTW, I tested with nautilus on debian linux sid.

Uwe

Hi Uwe,
here the short excerpt from the webdav log. doesn't seem particularly suspicious. I got an error (500) however and no file was created...

Is it normal for the webdav to not resolve spaces and special characters in paths correctly? maybe that could trace an error?

Code:
Oct 24 13:21:29  [debug] reverseLookup: path=/
Oct 24 13:21:29  [debug] reverseLookup: found folder DMS (1)
Oct 24 13:21:29  [info] check_auth: user=t.hagenau
Oct 24 13:21:29  [info] PROFIND: /
Oct 24 13:21:29  [debug] PROFIND: path=/
Oct 24 13:21:29  [debug] PROFIND: depth=1
Oct 24 13:21:29  [debug] PROFIND: props=array (
  0 =>
  array (
    'name' => 'creationdate',
    'xmlns' => 'DAV:',
  ),
  1 =>
  array (
    'name' => 'getcontentlength',
    'xmlns' => 'DAV:',
  ),
  2 =>
  array (
    'name' => 'getlastmodified',
    'xmlns' => 'DAV:',
  ),
  3 =>
  array (
    'name' => 'resourcetype',
    'xmlns' => 'DAV:',
  ),
)
Oct 24 13:21:29  [debug] reverseLookup: path=/
Oct 24 13:21:29  [debug] reverseLookup: found folder DMS (1)
Oct 24 13:21:37  [info] check_auth: user=t.hagenau
Oct 24 13:21:37  [info] checkLock: path=/HirnGespinste.pdf
Oct 24 13:21:37  [debug] reverseLookup: path=/HirnGespinste.pdf
Oct 24 13:21:37  [info] checkLock: object not found
Oct 24 13:21:37  [info] PUT: /HirnGespinste.pdf
Oct 24 13:21:37  [debug] PUT: path=/HirnGespinste.pdf
Oct 24 13:21:37  [debug] PUT: content_length=131906
Oct 24 13:21:37  [debug] PUT: content_type=application/octet-stream
Oct 24 13:21:37  [debug] PUT: stream=Resource id #44
Oct 24 13:21:37  [debug] reverseLookup: path=/
Oct 24 13:21:37  [debug] reverseLookup: found folder DMS (1)
Oct 24 13:21:47  [info] check_auth: user=t.hagenau
Reply
10-24-2011, 06:14 PM,
#16
RE: FTP acces to upload files and folder
(10-24-2011, 06:05 PM)gouwron Wrote: here the short excerpt from the webdav log. doesn't seem particularly suspicious. I got an error (500) however and no file was created...

Is it normal for the webdav to not resolve spaces and special characters in paths correctly? maybe that could trace an error?

The excerpt from the log looks fine. Special chars and spaces are always a source of trouble and clients behave quite differently. Just try without any special chars and spaces.

Uwe
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)

Contact Us | LetoDMS Community Forum | Return to Top | | Lite (Archive) Mode | RSS Syndication